Why Upgrade your Systems?

03/14/2014

If you’ve received a prompt to update your iPhone, iPad or iPod but you haven’t done it, you should do so immediately. The prompt would look like this: a red notification over the settings button.

Apple released the latest version of its mobile and tablet software, iOS7 and iOS6, in late February after discovering a security concern with its mobile operating systems. But in order for the updates to work, you must update your device.

And if you haven’t, you could be putting yourself at risk. Apple discovered a hole in its security that could allow hackers to jump in, on what you think, is a secure transaction on public Wi-Fi networks like at the library or a coffee shop. The hole affects the technologies that are supposed to encrypt the conversation between your browser and the server you’re trying to access when you visit a website. The only way to make sure your connection is secure is by updating your device.

The impacted devices are as follows:

  • iPhone 4 and later
  • iPod touch (5th generation)
  • iPad 2 and later

NOTE: Apple is reporting the same security issue exists in notebooks and desktops running the MAC OS X operating systems. Apple says they plan to release a software fix very soon.

Here are some additional screens you will see during the update process: